Project

General

Profile

e-mail anbindung

Added by Otmar Ripp almost 4 years ago

hallo,

mein e-mail Anbindung hat nicht sogleich geklappt :-(
"send email : Net::SMTP: connect: Connection refused ...propagated at /var/www/html/kivitendo-erp-release-3.3.0/SL/Mailer/SMTP.pm line 30."

Ich glaube er stirbt hier:

{port});

die unless $self->{smtp}; Hab folgende Einstellungen in kivitendo.conf:
[mail_delivery]
  1. Delivery method can be 'sendmail' or 'smtp' (the default). For
  2. 'method = sendmail' the parameter 'mail_delivery.sendmail' is used
  3. as the executable to call. If 'applications.sendmail' still exists
  4. (backwards compatibility) then 'applications.sendmail' will be used
  5. instead of 'mail_delivery.sendmail'.
    method = smtp
  6. Location of sendmail for 'method = sendmail'
    sendmail = /usr/sbin/sendmail -t<%if myconfig_email%> -f <%myconfig_email%><%end%>
  7. Settings for 'method = smtp'. Only set 'port' if your SMTP server
  8. runs on a non-standard port (25 for 'security=none' or
  9. 'security=tls', 465 for 'security=ssl').
    ##host = localhost
    host = smtp.charterware.net
    port = 25
  10. Security can be 'tls', 'ssl' or 'none'. Unset equals 'none'. This
  11. determines whether or not encryption is used and which kind. For
  12. 'tls' the module 'Net::SSLGlue' is required; for 'ssl'
  13. 'Net::SMTP::SSL' is required and 'none' only uses 'Net::SMTP'.
    security = tls
  14. Authentication is only used if 'login' is set. You should only use
  15. that with 'tls' or 'ssl' encryption.
    login = otmarmail
    password = "das richtige natürlich aber hier nicht veröffentlicht"

Hat jemand ne IDEE? aufgefallen war mir noch, dass in meinem e-mail client ICEDOVE bei Verbindungssicherheit STARTTLS steht, nicht tls.
Sodann ist die 2 malige "smtp" Angabe bei host=smtp.charterware.net und bei method=smtp richtig ?

Grüße Otmar


Replies (3)

e-mail anbindung, ich schaff es leider nicht, könnte jemand ohne lokalen e-mail server mal seine Einstellungen checken ? - Added by Otmar Ripp almost 4 years ago

hallo,

hab mich hier nochmal versucht, in meiner Icedove Config erreiche ich unseren e-mail server mit
Server: smtp.charterware.net
Port: 25
Benutzername: otmarmail
Authentifizierung: Passwort ungesichert
Verbindungssicherh: Keine

(Ich hab das mal versuchsweise so vereinfacht, normal haben wir STARTTLS und verschlüsseltes Passwort.)

Aber wenn ich das hier wie folgt in Kivi eintrage funktioniert es nicht.

method = smtp
host = smtp.charterware.net
port = 25
security = none
login = otmarmail
password = "das richtige natürlich aber hier nicht veröffentlicht"

Muss das passwort mit oder ohne " " sein ? Ich hab Sonderzeichen auch = drin.
Muss beim host das führende smtp. hin oder weg , weil es bei method ja nochmal steht ?
Wann werden solche und andere configs eigentlich grundsätzlich von Festplatte geladen ?
1. Akut Bedarfsweise immer?
2. beim 1. Bedarf bleiben dann geladen ?
3. beim Einloggen ?
3. Beim 1. Kivi Aufruf bis Serverneustart ?

Bin mir nie sicher ob ich bei config Änderungen mich ausloggen muss, oder gar Server Neustarten muss???
Nicht dass ich mir nur ein Bein stelle und meine config Änderungen richtig aber wirkungslos bleiben.

Vielleicht hat jemand noch einen Tip für mich :-)

Grüße Otmar

RE: e-mail anbindung - Added by Jan Büren almost 4 years ago

1.)
Beim Neustarten des Webservers
Also Dein Punkt 3)

2.)
password=geheim

Ich hab hier eine projektbezogene Config, die auch STARTTLS mit SMTP-Auth hat. Die sieht wie folgt aus:

[mail_delivery]
  1. Delivery method can be 'sendmail' or 'smtp' (the default). For
  2. 'method = sendmail' the parameter 'mail_delivery.sendmail' is used
  3. as the executable to call. If 'applications.sendmail' still exists
  4. (backwards compatibility) then 'applications.sendmail' will be used
  5. instead of 'mail_delivery.sendmail'.
    method = smtp
  6. Location of sendmail for 'method = sendmail'
    sendmail = /usr/sbin/sendmail -t<%if myconfig_email%> -f <%myconfig_email%><%end%>
  7. Settings for 'method = smtp'. Only set 'port' if your SMTP server
  8. runs on a non-standard port (25 for 'security=none' or
  9. 'security=tls', 465 for 'security=ssl').
    host = smtp.test.de
    #port = 578
  10. Security can be 'tls', 'ssl' or 'none'. Unset equals 'none'. This
  11. determines whether or not encryption is used and which kind. For
  12. 'tls' the module 'Net::SSLGlue' is required; for 'ssl'
  13. 'Net::SMTP::SSL' is required and 'none' only uses 'Net::SMTP'.
    security = tls
  14. Authentication is only used if 'login' is set. You should only use
  15. that with 'tls' or 'ssl' encryption.
    login =
    password = geheim

Die entsprechend Perl-Module (s.a. Kommentart) sind vorhanden?

Gruß,

RE: e-mail anbindung - Added by Otmar Ripp over 3 years ago

hallo,

hab mir das Thema nochmal vorgenommen, nachdem ich es vor Wochen partout mit smtp smartmailhost via unserem e-mail Server nicht schaffte.
Hab nun den Anderen Weg via exim4 auf dem kivi server versucht. Mit dpkg-reconfigure exim4-config
konservativ konfiguriert nur von localhost mails zu akzeptieren und nur zu senden, klappte sofort :-))

Ist denke ich ohnehin die bessere Wahl weil unabhängig von anderen Infrastrukturen.

Danke allemal !

Gruss Otmar

    (1-3/3)